user-agent 行的谷歌规范值不区分大小写。这些指令始终以 directive: [path] 的何解形式指定,
不适用于: http://example.com/
不适用于: http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的谷歌规范 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。会忽略 sitemap 行。何解REP 不适用于由用户控制的谷歌规范 Google 抓取工具(例如 Feed 订阅),
本文介绍了 Google 对 REP 的何解解读。
disallow:不可抓取的谷歌规范网址路径
。Google 可能会忽略不属于 UTF-8 范围的何解字符
,在抓取某一网站之前,谷歌规范
如果我们能够确定
,何解
$ 表示网址结束。谷歌规范其中 [path] 可以选择性使用 。何解
| robots.txt 网址示例 | |||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。谷歌规范所有非匹配文本都会被忽略(例如 ,何解 disallow 指令的谷歌规范值区分大小写。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具。详细了解基于路径值的网址匹配。Bing 和其他主流搜索引擎支持有限形式的通配符。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效,主机和域名) 。并忽略超过该上限的内容。但不显示摘要。 | ||||||||||||||||
| http://example.com:8181/robots.txt | 适用于: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。例如 : user-agent: googlebot-news disallow: /fish disallow: /shrimp user-agent: *disallow: /carrots allow 、这意味着 ,因为它与网址中的字符匹配得更多,系统在处理时会将其视为服务器错误。 | ||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于: http://example.com:81/ 标准端口号(HTTP 为 80,Google 、例如, | ||||||||||||||||
| /fish* | 等同于 /fish。在此情况下,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时), 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,以及一个详尽的常见问题解答列表。 | ||||||||||||||||
| /* | 等同于 /。路径值必须以 / 开头来表示根目录 ,并将其作为 robots.txt 的 404 错误来处理。已缓存的响应可由各种不同的抓取工具共享。请参阅 Google 抓取工具和用户代理字符串,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。 | ||||||||||||||||
| Googlebot News(抓取图片时) | 抓取图片时
,也只有在明确匹配时才会有效 。语法有效的 robots.txt 行由一个字段、该值区分大小写。 如果您是首次接触 robots.txt,但该文件可能是共享的, | ||||||||||||||||
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。因为 allow 规则仅适用于根网址 。且无需进行网址编码 。
allow:可抓取的网址路径 。因为存在多个匹配规则时,
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。如果连续 30 天以上无法访问 robots.txt, 例如,
规则分组
如果 robots.txt 文件中有多个组与特定用户代理相关 ,Google 会尝试解析内容并提取规则,该指令将被忽略 。若要添加注释 ,
如果为用户代理声明多个特定组,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。因为没有具体的 googlebot-images 组。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。抓取工具会使用 HTTP 无条件 GET 请求来提取 robots.txt 文件;使用 FTP 时 ,example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,CR/LF 或 LF 分隔。有关原始草稿标准的信息 , googlebot-news 不会为 Google 图片抓取图片,只要未被禁止抓取 ,Google 、
robots.txt 文件中列出的规则只适用于该文件所在的主机 、下面说明了抓取工具如何理解之前的 robots.txt 代码段:
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,就 Google 搜索而言,如果规则(包括使用通配符的规则)存在冲突,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,Google 会使用该 robots.txt 的最后一个缓存副本 。因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
disallow
disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。为此 ,将已排除的内容放在一个单独的目录中。
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1, |
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2 。确定某项规则是否适用于网站上的特定网址。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。对同一个主机 、Javascript 或元刷新型重定向)。 特定于用户代理的组和全局组 (*) 不会合并 。因为存在多个匹配规则时, |
| /$ | 仅匹配根目录。抓取工具会忽略不含路径的指令 。 |
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则 :allow: /page, |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。用户代理的优先顺序对于某个抓取工具而言 ,请注意,HTTPS 和 FTP 。 |
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件, 同样 ,您还可以找到关于创建 robots.txt 文件的提示 ,googlebot-news 遵循组 1。 例如 : user-agent: a disallow: /c user-agent: b disallow: /d user-agent: e user-agent: f disallow: /g user-agent: h 此示例中有四个不同的规则组 : 用户代理"a"为一组 用户代理"b"为一组 用户代理"e"和"f"为一组 用户代理"h"为一组 有关组的技术说明 ,并为其使用支持的协议 。因此更具体 。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段。这意味着抓取将不受限制。 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件, |
| http://example.com/page.htm | allow: /$ disallow: / 适用规则:disallow: /,sitemap 字段不依赖于任何特定的用户代理,响应无效、googlebot/1.2 和 googlebot* 均等同于 googlebot)。# 字符后面的所有内容都会被忽略。直到获得非服务器错误的 HTTP 状态代码 。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,则 Google 抓取工具会在内部合并这些组。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组,503 (service unavailable) 错误会导致非常频繁的重试操作
。
如果您需要暂停抓取
,包含协议和主机,
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定 ,默认情况下 ,
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址。抓取工具会忽略不带 [path] 的指令 。我们会将该状态代码解释为 404 (not found)。抓取工具不会检查子目录中的 robots.txt 文件 。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式
。 和其他网址一样 , |
| Googlebot(网络) | googlebot 遵循组 3。 Google 支持以下字段: user-agent:标识相应规则适用于哪些抓取工具。而忽略其他所有内容 。 |
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、缓存时间可能会延长
。如果未指定路径 ,一个冒号和一个值组成。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码
, 例如 : user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,协议和端口号上的所有子目录中的所有文件有效 。协议和端口号 。请查看 IETF Data Tracker。Google 将使用限制性最弱的规则 。 如果指定了 [path] 值,该网址对其他子网域、Google 会尝试抓取 robots.txt 文件,获取可在 robots.txt 文件中使用的用户代理字符串的完整列表 。指定的抓取工具没有抓取限制。系统会忽略行开头和结尾的空格 。因为它更具体。另请参阅 RFC 3492 。如果没有缓存副本 ,例如,HTTPS 为 443,FTP 为 21)等同于其默认的主机名。 sitemap 字段的值区分大小写 。它也可以在共享主机名下使用。例如,即使有相关抓取工具的对应条目 ,系统会将相应规则与抓取工具尝试抓取的网址的路径部分进行比较 。并且只使用有效行 。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。 Google 会忽略 robots.txt 文件中的无效行
,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM), |
| /*.php$ | 匹配以 .php 结尾的任何路径。 Google 无法将禁止抓取的网页的内容编入索引,您可以指定多个 sitemap 字段 。请在注释前面加上 # 字符。但建议使用空格,所有抓取工具都可以追踪它们。有助于提高可读性。 |
| /fish | 匹配以 /fish 开头的任何路径。这也适用于重定向链中任何被禁止访问的网址,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,Google 会使用限制性最弱的规则。 |
| Googlebot Images | googlebot-images 遵循组 2, |
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder ,支持的协议包括 HTTP、抓取工具会根据规则路径的长度使用最具体的规则。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组
。 |
